Slow dashboard and delays in email delivery
Resolved·Degraded performance

We processed the queued emails. Delivery speed and dashboard latency have returned to normal. Thank you for your patience.

Tue, Oct 28, 2025, 09:49 PM
(1 month ago)
·
Affected components
General API
Email Events
Webhooks
Dashboard
Updates

Resolved

We processed the queued emails. Delivery speed and dashboard latency have returned to normal. Thank you for your patience.

Tue, Oct 28, 2025, 09:49 PM

Identified

We've deployed the fix and are now working through the queued emails as the latency improves.

Tue, Oct 28, 2025, 09:38 PM(10 minutes earlier)

Identified

We've identified the cause of the increased latency and are working to deploy a fix.

Tue, Oct 28, 2025, 09:08 PM(29 minutes earlier)

Identified

We are currently investigating increased latency in email sending and in the dashboard. At this time, you may experience delays when sending emails via our SMTP service and API. No emails will be lost. We have identified the issue and we are working on a fix now.

Tue, Oct 28, 2025, 08:28 PM(40 minutes earlier)