Resolved
This incident has been resolved. Email sending and dashboard performance are both operating normally. Thank you for your patience while we worked through this.
Monitoring
Email events are now up-to-date. We're continuing to monitor the dashboard and email sending.
Monitoring
Email sending is back to normal. All previously queued emails have been successfully delivered. While we continue to improve dashboard performance, some email events may appear as "Queued" or not yet be visible in the dashboard. This is a display issue only; delivery is unaffected.
Identified
While emails are sending, they're currently delayed and so are the email events (delivered, opened, clicked, etc.)
Identified
We're continuing to investigate intermittent errors with the dashboard. Emails are being received, though they are being sent with a delay.
Identified
We're seeing improved dashboard performance and are working on email sending latency. Emails are being received, though they are being sent with a delay.
Investigating
We are currently investigating increased latency in email sending. Emails are being received, though they are being sent with a delay.
Investigating
We're currently investigating an incident with our dashboard