Resolved
Performance is back to normal.
Monitoring
Sending speed is back to normal. We'll continue to monitor.
Identified
We've identified the cause of the latency and are working to mitigate it so we can return to normal sending speed.
Investigating
We are currently investigating increased latency in email sending. At this time, you may experience delays when sending emails via our SMTP service and API.
Investigating
We are currently investigating increased latency in email sending. Emails are being accepted, though sent at a slower speed than expected.