Resend

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Email sending delay
Resolved·Degraded performance

We have resolved the underlying issue and service has been resumed.

Tue, Mar 3, 2026, 07:47 AM
(3 months ago)
·
Affected components
Mar 3, 2026, 07:38 AM
07:47 AM
SMTP
Updates

Resolved

We have resolved the underlying issue and service has been resumed.

Tue, Mar 3, 2026, 07:47 AM

Investigating

We are currently investigating increased latency in email sending. At this time, you may experience delays when sending emails via our SMTP service and API.

Tue, Mar 3, 2026, 07:38 AM