Resolved
The pending domain verifications and broadcasts are catching-up quickly. The incident should fully resolve soon.
Monitoring
The underlying issue has been identified and our third-party provider has pushed improvements. We're seeing an improvement in domain verifications and broadcast email throughput. We'll continue to monitor the situation and work on mitigation actions.
Monitoring
We've identified the root cause. We're working with a third-party provider to solve the underlying issue as we work on mitigation actions. In addition to Broadcasts, Domain verification may take longer than usual.
Investigating
We are currently investigating an increase in latency when sending Broadcasts