Resolved
The processing backlog is fully cleared. All systems are operational.
Identified
We're continuing to work through the backlog of events.
Identified
We've identified the cause of the Queued events are currently working through the backlog of events.
Investigating
We are currently investigating increased latency in email events being updated.