Resolved
This incident is resolved. Email events are updating in real time and have been stable since our fix was deployed. Sending and delivery were unaffected throughout. Thank you for your patience.
Monitoring
All queued events have caught up, and email events are now updating in real time. We're monitoring our changes to confirm this is resolved.
Identified
We've identified the cause of the delay in email events updating and deployed a fix. Event statuses are beginning to catch up. Emails continue to be sent and delivered as normal. Only the displayed status was affected.
Investigating
We're continuing to investigate the source of email events not updating, and showing a Queued status. Emails are being sent/delivered.
Investigating
We are currently investigating a delay in updating of email events. Emails are being sent/delivered, though the events may display as Queued.