Resolved
This incident is resolved. Webhook deliveries and metrics page updates have been stable since our fix was deployed. Sending and receiving were unaffected throughout. Thanks for your patience.
Monitoring
We've deployed a fix for the delayed events. Webhook deliveries and email event statuses have caught up and are updating in real time. We're monitoring to confirm the fix holds.
Identified
We've identified the cause of the delay in email events. Event statuses are beginning to catch up. Emails continue to be sent and delivered as normal. Only the displayed status was affected.
Investigating
We are currently investigating a delay in updating of email events. Emails are being sent/delivered, though the events may display as Queued.