Resolved
We have resolved the underlying issue by reverting the unintended breaking change and service has been resumed.
Identified
A recent change to how Resend processes inbound emails affected customers who receive emails via server-side forwarding rules, where a mail server automatically redirects an email to a different address without rewriting its headers.
When an email is forwarded this way to a Resend inbound address, the to field in the inbound webhook payload began reflecting the original "To" header (e.g. support@yourcompany.com) rather than the address that actually received the delivery (e.g. your Resend inbound address).
Direct emails and client-side forwards were not affected.