We have resolved the underlying issue and service has been resumed.
Tue, May 26, 2026, 03:36 PM
(2 hours ago)
·
Affected components
Dashboard
Updates
Resolved
We have resolved the underlying issue and service has been resumed.
Tue, May 26, 2026, 03:36 PM
Investigating
We are currently investigating increased latency in Resend dashboard. At this time, you may experience delays and errors while trying to access our dashboard.
Tue, May 26, 2026, 03:29 PM
Resend dashboard facing intermittent errors - Resend Status