Resend

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Issues downloading attachments
Resolved·Degraded performance

We have resolved the underlying issue and service has been resumed.

Mon, Jun 15, 2026, 09:14 PM
(19 hours ago)
·
Affected components
Jun 15, 2026, 07:55 PM
08:40 PM
General API
Updates

Resolved

We have resolved the underlying issue and service has been resumed.

Mon, Jun 15, 2026, 09:14 PM

Monitoring

The fix for downloading email attachments has been pushed and we are now monitoring the situation.

Mon, Jun 15, 2026, 08:40 PM(33 minutes earlier)

Investigating

We are currently investigating issues with downloading attachments where existing download URLs would incorrectly return a 403 response.

Mon, Jun 15, 2026, 07:55 PM(45 minutes earlier)