Resolved
We have resolved the underlying issue and service has been resumed.
Monitoring
The deployment has been completed, and we're still monitoring. Latency has stabilized since 13:38 UTC.
Identified
We have identified the issue and are deploying a fix now. The team is monitoring. Latency has recovered, but we're keeping this incident open for the next few minutes to monitor downstream services.
Investigating
We're noticing increased API latency across different endpoints, causing delays in email sending.