Resolved
We have resolved the underlying issue and service has been resumed.
Investigating
We are currently investigating increased latency in contact imports via CSV files and automation runs. At this time, you may experience delays in the processes that rely on these features.