Between approximately 17:30 and 17:43 UTC, requests to add a new domain failed in the dashboard and through the public API (POST /domains). Verification of domains added during this window was also affected. The issue was identified and fixed, and domain creation has returned to normal. No domains were partially created: affected requests failed immediately, so retrying the domain creation will succeed. Email sending for existing domains was not affected.
Resolved
Between approximately 17:30 and 17:43 UTC, requests to add a new domain failed in the dashboard and through the public API (POST /domains). Verification of domains added during this window was also affected. The issue was identified and fixed, and domain creation has returned to normal. No domains were partially created: affected requests failed immediately, so retrying the domain creation will succeed. Email sending for existing domains was not affected.
Investigating
We identified an increase in errors during the domain creation process