Back to overview
Downtime

API and Dashboard inaccessible

Feb 20 at 09:02pm PST
Affected services
Resend API
Resend SMTP Relay

Resolved
Feb 22 at 09:32am PST

We have posted a postmortem on our blog:
https://resend.com/blog/incident-report-for-february-21-2024

Updated
Feb 21 at 09:14am PST

Everything is back to normal now.

We are continuing to monitor all systems and will provide a more extensive postmortem soon.

Updated
Feb 21 at 09:04am PST

The database restoration is complete. Sending is now continuing and dashboard access should be available shortly.

Updated
Feb 21 at 08:09am PST

The database restoration process is still underway and is running as expected. Further updates in an hour.

Updated
Feb 21 at 07:18am PST

We are continuing the database restoration process and will keep sharing updates every hour.

Updated
Feb 21 at 06:05am PST

The database restoration process is still in progress and we’ll keep sharing updates every hour.

Updated
Feb 21 at 05:05am PST

We are continuing the database restoration process and will keep sharing updates every hour.

Updated
Feb 21 at 04:10am PST

Unfortunately, the initial backup restoration process failed. A new backup restoration process is starting now, and it could take up to 6 hours for the database to recover. We deeply appreciate your patience and understanding throughout this process.

Updated
Feb 21 at 03:29am PST

Database schema, tables, and indexes have been recovered. However, the content of each table is still being recovered. Please bear with us as we continue the restore process.

Updated
Feb 21 at 03:03am PST

We are continuing the database restoration process and will keep sharing updates every hour.

Updated
Feb 21 at 02:06am PST

The database restoration process is still in progress and we’ll keep sharing updates every hour.

Updated
Feb 21 at 01:11am PST

We are continuing the database restoration process and will keep sharing updates every hour.

Updated
Feb 21 at 12:02am PST

The database restoration process is still in progress and we’ll keep sharing updates every hour.

Updated
Feb 20 at 11:05pm PST

We are continuing the database restoration process and will keep sharing updates every hour.

Updated
Feb 20 at 10:01pm PST

We had to perform an emergency database restoration. Unfortunately, this process can take up to several hours. We deeply appreciate your patience and understanding throughout this process.

Updated
Feb 20 at 09:10pm PST

We have identified the root cause, and we're performing an emergency fix.

Created
Feb 20 at 09:02pm PST

We noticed an increased error rate for requests to our API. We are investigating a fix.