Our background functions are taking longer to execute
Resolved·Degraded performance

We have resolved the underlying issue and service has been resumed.

Thu, Jul 17, 2025, 02:32 PM
(1 week ago)
·
Affected components
Updates

Resolved

We have resolved the underlying issue and service has been resumed.

Thu, Jul 17, 2025, 02:32 PM

Monitoring

Function execution has been fully restored. We continue to monitor the system to ensure that behavior is as expected.

Thu, Jul 17, 2025, 01:59 PM(33 minutes earlier)

Monitoring

A fix has been put in place for our third party provider and the system is beginning recovery

Thu, Jul 17, 2025, 01:48 PM(11 minutes earlier)

Investigating

We are currently investigating increased latency in our background function due to errors with our third-party provider.

At this time, you may experience delays when sending batches and broadcast emails. Domains verifications can also be delayed.

Thu, Jul 17, 2025, 01:17 PM(31 minutes earlier)