Degraded service performance
Resolved·Degraded performance

We have resolved the underlying issue and service has been resumed.

Sat, Aug 30, 2025, 01:23 PM
(2 weeks ago)
·
Affected components
Email Events
Dashboard
Updates

Resolved

We have resolved the underlying issue and service has been resumed.

Sat, Aug 30, 2025, 01:23 PM

Monitoring

The fix has been pushed and we are now monitoring the situation.

Sat, Aug 30, 2025, 01:07 PM(16 minutes earlier)

Investigating

We are currently investigating increased latency in email sending. At this time, you may experience delays when sending emails via our SMTP service and API.

Sat, Aug 30, 2025, 12:52 PM(15 minutes earlier)