Email event status incorrect for newly created domains
Resolved·Degraded performance

We have resolved the underlying issue and service has been resumed. We have contacted the impacted teams.

Thu, Sep 11, 2025, 07:23 PM
(4 days ago)
·
Affected components
Email Events
Updates

Resolved

We have resolved the underlying issue and service has been resumed. We have contacted the impacted teams.

Thu, Sep 11, 2025, 07:23 PM

Investigating

We are currently investigating an issue with our email event status. At this time, newly created domains may be configured incorrectly, preventing proper updates to email event statuses (including sent, delivered, bounced, and complained events). Your emails are being sent and delivered as expected, but you may notice that emails are incorrectly marked as Queued in your dashboard. This will also impact webhooks from POSTing on events.

Wed, Sep 10, 2025, 04:26 PM(1 day earlier)