Link Redirection Issue - Spectrum ISP Users
Resolved·Degraded performance

We have resolved the issue with redirects at Spectrum.

Fri, Oct 10, 2025, 04:47 PM
(1 month ago)
·
Affected components
General API
Updates

Resolved

We have resolved the issue with redirects at Spectrum.

Fri, Oct 10, 2025, 04:47 PM

Investigating

We are currently investigating an issue where tracked links are not redirecting properly for email recipients using Spectrum as their ISP.

Fri, Oct 10, 2025, 03:21 AM(13 hours earlier)