Increased error rate in email sending across all regions
Resolved·Partial outage

All services have been fully restored, and systems are operating normally. If you have any questions or notice anything unusual, please don’t hesitate to reach out to our support team.

Mon, Oct 20, 2025, 01:04 PM
(2 weeks ago)
·
Affected components
Email Events
Updates

Resolved

All services have been fully restored, and systems are operating normally. If you have any questions or notice anything unusual, please don’t hesitate to reach out to our support team.

Mon, Oct 20, 2025, 01:04 PM

Monitoring

All services have been fully restored. Our team will continue to monitor closely over the next few hours to ensure stability.

Mon, Oct 20, 2025, 10:47 AM(2 hours earlier)

Monitoring

Email sending has fully recovered. Some email events may continue to experience delays as we process the remaining backlog from the outage.

Mon, Oct 20, 2025, 10:25 AM(22 minutes earlier)

Monitoring

We’re seeing signs of recovery, but some requests and services may still experience some delays as we fully process the backlog of messages.

Mon, Oct 20, 2025, 09:40 AM(44 minutes earlier)

Identified

The upstream provider issue is still ongoing, and email sending remains impacted. Single Emails, SMTP and Scheduled Emails are being queued and will be retried once the issue is resolved.

Mon, Oct 20, 2025, 09:23 AM(17 minutes earlier)

Identified

We’ve confirmed an issue with a third-party provider that’s impacting email sending across all regions. We’re actively working to restore the services as soon as possible.

Mon, Oct 20, 2025, 07:36 AM(1 hour earlier)

Investigating

We’re currently investigating an increased error rate when sending emails from the us-east-1 region.

Mon, Oct 20, 2025, 07:14 AM(22 minutes earlier)