Resolved
We have resolved the underlying issue and service has been resumed.
Identified
We have identified that some existing customers are unable to verify domains in us-east-1. New customers would not have problems creating domains in us-east-1. We are working on a fix.
Investigating
We are currently investigating delays in domain verification for domains created in the us-east-1 region. We’ll share updates as we learn more.