Increased latency in transactional email sending
Resolved·Degraded performance

We have confirmed the issue is resolved, no emails have been lost, and no further action needs to be taken for now.

Tue, Jan 13, 2026, 07:28 PM
(2 weeks ago)
·
Affected components
Updates

Resolved

We have confirmed the issue is resolved, no emails have been lost, and no further action needs to be taken for now.

Tue, Jan 13, 2026, 07:28 PM

Monitoring

We have identified an issue that caused a small increase in latency in email sending for a few minutes, starting at around 5:52 PM UTC and ending at 6 PM UTC. Emails sent during that time will have experienced increased latency.

We have taken the necessary actions to fix the issue and no emails have been lost. We're monitoring the performance of email sending to ensure the latency is back to normal.

Tue, Jan 13, 2026, 06:09 PM(1 hour earlier)