Delay email sending
Resolved·Degraded performance

We have resolved the underlying issue, and email sending has returned to normal. Thank you for your patience while we worked through this. If you have any questions or concerns, please don’t hesitate to reach out to support@resend.com.

Tue, Jan 20, 2026, 02:07 PM
(1 week ago)
·
Affected components
General API
Updates

Resolved

We have resolved the underlying issue, and email sending has returned to normal. Thank you for your patience while we worked through this. If you have any questions or concerns, please don’t hesitate to reach out to support@resend.com.

Tue, Jan 20, 2026, 02:07 PM

Monitoring

The fix has been pushed, and we are now monitoring. Queued emails are being processed.

Tue, Jan 20, 2026, 01:45 PM(22 minutes earlier)

Investigating

We are currently investigating sending delays. Currently, email requests are returning a 200 status, but you may notice a delay in sending. All emails are being queued and will be processed as soon as the issue is resolved.

Tue, Jan 20, 2026, 01:37 PM