Increased latency in transactional email sending
Resolved·Degraded performance

All systems are operating normally and no emails were lost.

Wed, Jan 21, 2026, 02:19 PM
(1 week ago)
·
Affected components
Updates

Resolved

All systems are operating normally and no emails were lost.

Wed, Jan 21, 2026, 02:19 PM

Monitoring

We observed an unusual spike in traffic. No emails were lost. Systems have returned to normal and we are continuing to monitor.

Wed, Jan 21, 2026, 01:44 PM(34 minutes earlier)

Investigating

We are currently investigating increased latency in email sending. At this time, you may experience delays when sending emails via our SMTP service and API.

Wed, Jan 21, 2026, 01:23 PM(20 minutes earlier)