Microsoft 365 Incident
Resolved·Degraded performance

Microsoft is reporting that email is returning to normal sending, with its most recent update stating, "We have a high level of confidence that the incident is largely resolved." From our own metrics, we're also seeing "Delivery Delayed" events reduce, with deliveries now happening upon retry.

Fri, Jan 23, 2026, 05:48 AM
(1 week ago)
·
Affected components
Email Events
Updates

Resolved

Microsoft is reporting that email is returning to normal sending, with its most recent update stating, "We have a high level of confidence that the incident is largely resolved." From our own metrics, we're also seeing "Delivery Delayed" events reduce, with deliveries now happening upon retry.

Fri, Jan 23, 2026, 05:48 AM

Monitoring

Microsoft is continuing to investigate and work towards mitigating the incident impacting Microsoft 365. We will continue to monitor their updates. Emails experiencing "Delivery Delayed" will continue to retry.

Fri, Jan 23, 2026, 12:07 AM(5 hours earlier)

Monitoring

Microsoft 365 is currently experiencing an incident, which is degrading its ability to accept email. While this is not a Resend incident, it is possible to see an elevated amount of "Delivery Delay" events if Microsoft is unable to accept the email.

With our Delivery Delayed events, we will retry delivery. Once Microsoft resolves its incident, sending to these addresses will return to normal.

Thu, Jan 22, 2026, 09:16 PM(2 hours earlier)