Delays in email sending
Resolved·Degraded performance

Our systems have caught up with the delayed emails and are healthy again. No emails were lost during the period of degraded performance.

Tue, Jan 27, 2026, 05:50 PM
(2 days ago)
·
Affected components
Email Events
Updates

Resolved

Our systems have caught up with the delayed emails and are healthy again. No emails were lost during the period of degraded performance.

Tue, Jan 27, 2026, 05:50 PM

Monitoring

We have identified the issue causing delays in email delivery. Our services are processing the backlog and should be up to date within a few minutes.

Also, we want to make it clear that no emails were lost.

Tue, Jan 27, 2026, 05:43 PM

Investigating

We are currently investigating increased latency in email sending. At this time, you may experience delays when sending emails via our SMTP service and API.

Tue, Jan 27, 2026, 05:19 PM(23 minutes earlier)