Resend

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Latency increased for all background actions
Resolved·Degraded performance

We have resolved the underlying issue and service has been resumed.

Tue, Feb 3, 2026, 11:21 PM
(1 month ago)
·
Affected components
Feb 3, 2026, 09:13 PM
10:56 PM
General API
Dashboard
Updates

Resolved

We have resolved the underlying issue and service has been resumed.

Tue, Feb 3, 2026, 11:21 PM

Monitoring

The fix has been pushed and we are now monitoring the situation.

Tue, Feb 3, 2026, 10:59 PM(22 minutes earlier)

Investigating

We have identified an issue with a third-party provider who's responsible for background actions like verifying domains, importing contacts, sending broadcasts and a few other tasks. Transactional email sending is not impacted.

Tue, Feb 3, 2026, 07:30 PM(3 hours earlier)