Resolved
We have resolved the underlying issue and service has been resumed.
Identified
We had a time window from 17:42 PM UTC to 17:48 PM UTC during which our API returned 50x errors for a subset of requests.
The root cause has been identified and addressed. The API is now recovered and our team is monitoring.