It was a false alert. It was caused by a combination of an ongoing incident with the third‑party observability service we use and some internal, isolated infrastructure experiments.
Emails have been sent smoothly and there have been no delays.
Resolved
It was a false alert. It was caused by a combination of an ongoing incident with the third‑party observability service we use and some internal, isolated infrastructure experiments.
Emails have been sent smoothly and there have been no delays.
Investigating
We are currently investigating increased latency in email sending. At this time, you may experience delays when sending emails via our SMTP service and API.
No emails will be lost.