Resolved
Broadcast sending has returned to normal speed. Queue times are back to expected levels. Thank you for your patience.
Investigating
We're investigating longer-than-expected queue times for Broadcasts. Delivery is still occurring, but at a reduced pace. We'll provide updates as we learn more.