No components marked as affected
Identified
We've identified that Microsoft addresses (outlook.com, hotmail.com, and other Microsoft-owned domains) are experiencing delivery delays at an elevated rate.
We've informed Microsoft and are monitoring.
Investigating
We are currently investigating an issue affecting deliverability to Microsoft inbox providers. At this time, some emails sent to Outlook.com, Hotmail.com, and other Microsoft-owned domains may experience delivery delays.