No components marked as affected
Resolved
This incident is resolved. All failed provisioning requests have been reprocessed, and custom tracking domain creation is operating normally.
Monitoring
Issue identified and resolved for new requests.
New customers can now create custom tracking domains again. We're replaying the failed provisioning requests from the outage window. This may take some time to fully process.
Investigating
Since 09:45 UTC on May 5, 2026, new customers are unable to create custom tracking domains. Existing tracking domains and email sending are not affected.
We've identified the cause as an upstream infrastructure limit and are working with our provider to resolve it.