No components marked as affected
Resolved
Delivery to Microsoft has returned to normal. Thank you for your patience as we worked with them regarding this.
Monitoring
We've received word from Microsoft that they've addressed the cause of the bounces. While it may still be possible to see emails in the Delivery Delayed status while we wait on retry, newly sent emails are now Delivered.
Investigating
We're continuing to investigate the causes of Deliverability Delayed events with Microsoft and working with them directly. Thank you for your patience as we investigate this.
Investigating
We're currently investigating reports of an increase in Delivery Delayed events to Microsoft-hosted email addresses.