Resolved
We have resolved the underlying issue, and service has resumed. Domain verification has been restored, and affected verifications were re-triggered.
Identified
We have identified the issue with domain verifications both through the dashboard and public API.