Resolved
We have resolved the underlying issue and service latency has been recovered.
Identified
We have identified the issue and deployed a fix. API latency has recovered since then. Our team is still monitoring to ensure it remains stable over the next few minutes.
Investigating
We are currently investigating increased latency in non-email sending API endpoints. Our team is investigating it.